import Foundation
let pattern = #"^[A-Za-z ]+(?:-[A-Za-z]{0,3})?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .allowCommentsAndWhitespace])
let testString = #"""
A
An
Any
Any
Any w
Any wo
Any wor
Any word
Any words
Any words -
Any words -A
Any words -AJ
Any words -AJW
Any words -AJWa
Any words -AJWab
Any words -AJWabc
-
-A
-AJ
-AJW
-AJW-
-AJW-A
-AJW-AJ
-AJW-AJW
And not Anywords-anywords-AJW
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)