#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "12345679810"
Local $sString = "1" & @CRLF & _
"2" & @CRLF & _
"123" & @CRLF & _
"1234" & @CRLF & _
"12345679810"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")