$re = '/12345679810/';
$str = '1
2
123
1234
12345679810';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);