package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`12345679810`)
var str = `1
2
123
1234
12345679810`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}