const regex = new RegExp('\\b\\d+(?:_\\d+)+\\b', '')
const str = `most popular data structure in OOP lists/5438_133195_9917949_1218833? povid=racking these benchmarks`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}