re = /\b\d+(?:_\d+)+\b/
str = 'most popular data structure in OOP lists/5438_133195_9917949_1218833? povid=racking these benchmarks'
# Print the match result
str.match(re) do |match|
puts match.to_s
end