import re
regex = re.compile(r"\b\d+(?:_\d+)+\b")
test_str = "most popular data structure in OOP lists/5438_133195_9917949_1218833? povid=racking these benchmarks"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")