using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((^, @|@\s+)|@*[a-zA-Z0-9]* +[a-zA-Z0-9])";
string input = @"@tag1,@tag2
@tag1, @tag2
@tag1
@tag 1
@tag 1, @t a g2
@t ag 1, @tag 2
@tag1, @ tag sdf-sdf
@tag 1, @ tag2
tag acb";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}