const regex = /((^, @|@\s+)|@*[a-zA-Z0-9]* +[a-zA-Z0-9])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((^, @|@\\s+)|@*[a-zA-Z0-9]* +[a-zA-Z0-9])', 'g')
const str = `@tag1,@tag2
@tag1, @tag2
@tag1
@tag 1
@tag 1, @t a g2
@t ag 1, @tag 2
@tag1, @ tag sdf-sdf
@tag 1, @ tag2
tag acb`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}