use strict;
my $str = '@tag1,@tag2
@tag1, @tag2
@tag1
@tag 1
@tag 1, @t a g2
@t ag 1, @tag 2
@tag1, @ tag sdf-sdf
@tag 1, @ tag2
tag acb';
my $regex = qr/((^, @|@\s+)|@*[a-zA-Z0-9]* +[a-zA-Z0-9])/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}