// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"((^, @|@\s+)|@*[a-zA-Z0-9]* +[a-zA-Z0-9])").unwrap();
let string = "@tag1,@tag2
@tag1, @tag2
@tag1
@tag 1
@tag 1, @t a g2
@t ag 1, @tag 2
@tag1, @ tag sdf-sdf
@tag 1, @ tag2
tag acb";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}