import Foundation
let pattern = #"((^, @|@\s+)|@*[a-zA-Z0-9]* +[a-zA-Z0-9])"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
@tag1,@tag2
@tag1, @tag2
@tag1
@tag 1
@tag 1, @t a g2
@t ag 1, @tag 2
@tag1, @ tag sdf-sdf
@tag 1, @ tag2
tag acb
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)