#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^resource:\/\/((?<flowPackageKey>[a-z0-9]+\.(?:[a-z0-9][\.a-z0-9]*)+)|(?<composerPackageName>[^\/]+\/[^\/]+))(?<path>.*)$"
Local $sString = "resource://Neos.Neos.Ui/Public/Styles/Host.css" & @CRLF & _
"resource://neos/neos-ui-compiled/Public/Styles/Host.css" & @CRLF & _
"resource://some weird/composer_name/Public/Styles/Host.css" & @CRLF & _
"resource://Neos.Flow/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")