// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)^resource:\/\/((?<flowPackageKey>[a-z0-9]+\.(?:[a-z0-9][\.a-z0-9]*)+)|(?<composerPackageName>[^\/]+\/[^\/]+))(?<path>.*)$").unwrap();
let string = "resource://Neos.Neos.Ui/Public/Styles/Host.css
resource://neos/neos-ui-compiled/Public/Styles/Host.css
resource://some weird/composer_name/Public/Styles/Host.css
resource://Neos.Flow/";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}