re = /^resource:\/\/((?<flowPackageKey>[a-z0-9]+\.(?:[a-z0-9][\.a-z0-9]*)+)|(?<composerPackageName>[^\/]+\/[^\/]+))(?<path>.*)$/mi
str = 'resource://Neos.Neos.Ui/Public/Styles/Host.css
resource://neos/neos-ui-compiled/Public/Styles/Host.css
resource://some weird/composer_name/Public/Styles/Host.css
resource://Neos.Flow/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end