import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^resource:\\/\\/((?<flowPackageKey>[a-z0-9]+\\.(?:[a-z0-9][\\.a-z0-9]*)+)|(?<composerPackageName>[^\\/]+\\/[^\\/]+))(?<path>.*)$";
final String string = "resource://Neos.Neos.Ui/Public/Styles/Host.css\n"
+ "resource://neos/neos-ui-compiled/Public/Styles/Host.css\n"
+ "resource://some weird/composer_name/Public/Styles/Host.css\n"
+ "resource://Neos.Flow/";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}