using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^resource:\/\/((?<flowPackageKey>[a-z0-9]+\.(?:[a-z0-9][\.a-z0-9]*)+)|(?<composerPackageName>[^\/]+\/[^\/]+))(?<path>.*)$";
string input = @"resource://Neos.Neos.Ui/Public/Styles/Host.css
resource://neos/neos-ui-compiled/Public/Styles/Host.css
resource://some weird/composer_name/Public/Styles/Host.css
resource://Neos.Flow/";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}