#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(.*?)([[:alnum:]]+)(::)(.*?)|."
Local $sString = "library(ggplot2)" & @CRLF & _
"library(ggplot2, verbose = TRUE)" & @CRLF & _
"library(ggplot2, stringr)" & @CRLF & _
"library("ggplot2")" & @CRLF & _
"library("ggplot2", "yarrr")" & @CRLF & _
"require(stringr)" & @CRLF & _
"#' @import fields" & @CRLF & _
"#' @importFrom neotoma compile_taxa" & @CRLF & _
"neotoma::get_dataset()" & @CRLF & _
"dataset %>% dplyr::filter(value > 10) %>% DT::datatable()"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")