using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*?)([[:alnum:]]+)(::)(.*?)|.";
string input = @"library(ggplot2)
library(ggplot2, verbose = TRUE)
library(ggplot2, stringr)
library(""ggplot2"")
library(""ggplot2"", ""yarrr"")
require(stringr)
#' @import fields
#' @importFrom neotoma compile_taxa
neotoma::get_dataset()
dataset %>% dplyr::filter(value > 10) %>% DT::datatable()";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}