$re = '/(.*?)([[:alnum:]]+)(::)(.*?)|./m';
$str = 'library(ggplot2)
library(ggplot2, verbose = TRUE)
library(ggplot2, stringr)
library("ggplot2")
library("ggplot2", "yarrr")
require(stringr)
#\' @import fields
#\' @importFrom neotoma compile_taxa
neotoma::get_dataset()
dataset %>% dplyr::filter(value > 10) %>% DT::datatable()';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);