using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^""']*jquery[\-\d.]*\.min\.js[^""']*)";
string input = @"""https://code.jquery.com/jquery-3.5.1.min.js?abc=1""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}