$re = '/([^"\']*jquery[\-\d.]*\.min\.js[^"\']*)/m';
$str = '"https://code.jquery.com/jquery-3.5.1.min.js?abc=1"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);