#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(ONE)?TWO(?(1)(THREE)?|THREE)"
Local $sString = "$20,000 AUD" & @CRLF & _
"$20,000" & @CRLF & _
"20,000 AUD" & @CRLF & _
"20,000" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"ONE" & @CRLF & _
"TWO" & @CRLF & _
"THREE" & @CRLF & _
"ONETWO" & @CRLF & _
"ONETHREE" & @CRLF & _
"TWOTHREE" & @CRLF & _
"ONETWOTHREE"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")