$re = '/(ONE)?TWO(?(1)(THREE)?|THREE)/m';
$str = '$20,000 AUD
$20,000
20,000 AUD
20,000
ONE
TWO
THREE
ONETWO
ONETHREE
TWOTHREE
ONETWOTHREE';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);