re = /(ONE)?TWO(?(1)(THREE)?|THREE)/m
str = '$20,000 AUD
$20,000
20,000 AUD
20,000
ONE
TWO
THREE
ONETWO
ONETHREE
TWOTHREE
ONETWOTHREE'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end