package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(ONE)?TWO(?(1)(THREE)?|THREE)`)
var str = `$20,000 AUD
$20,000
20,000 AUD
20,000
ONE
TWO
THREE
ONETWO
ONETHREE
TWOTHREE
ONETWOTHREE`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}