using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(ONE)?TWO(?(1)(THREE)?|THREE)";
string input = @"$20,000 AUD
$20,000
20,000 AUD
20,000
ONE
TWO
THREE
ONETWO
ONETHREE
TWOTHREE
ONETWOTHREE";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}