import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\,(?=\\s*?[\\}\\]])";
final String string = "[ \n"
+ " { \n"
+ " \"ITEM1\":{ \n"
+ " \"names\":[ \n"
+ " \"nameA\",\n"
+ " ]\n"
+ " }\n"
+ " },\n"
+ " { \n"
+ " \"ITEM2\":{ \n"
+ " \"names\":[ \n"
+ " \"nameB\",\n"
+ " \"nameC\",\n"
+ " ],\n"
+ " \"linear\": [\"nameD\", \"nameE\", ],\n"
+ " \"chars\": \"a, b, c,\"\n"
+ " }\n"
+ " },\n"
+ "]";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}