$re = '/\,(?=\s*?[\}\]])/';
$str = '[
{
"ITEM1":{
"names":[
"nameA",
]
}
},
{
"ITEM2":{
"names":[
"nameB",
"nameC",
],
"linear": ["nameD", "nameE", ],
"chars": "a, b, c,"
}
},
]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);