re = /\,(?=\s*?[\}\]])/
str = '[
{
"ITEM1":{
"names":[
"nameA",
]
}
},
{
"ITEM2":{
"names":[
"nameB",
"nameC",
],
"linear": ["nameD", "nameE", ],
"chars": "a, b, c,"
}
},
]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end