using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<p>(?=<img\s.*?))(.*?)(</p>)";
string substitution = @"<figure class=""image"">\2</figure>";
string input = @"<p><img src=""/files/ffea8817-b5c4-406e-a7b2-3f6e52c69398.png"" style=""height:901px; width:797px"" /></p>
<p><img src=""/files/ffea8817-b5c4-406e-a7b2-3f6e52c69398.png"" style=""height:901px; width:797px"" /></p>
<p><img src=""/files/ffea8817-b5c4-406e-a7b2-3f6e52c69398.png"" style=""height:901px; width:797px"" /></p>
<p><img src=""/files/ffea8817-b5c4-406e-a7b2-3f6e52c69398.png"" style=""height:901px; width:797px"" /></p><p><img src=""/files/ffea8817-b5c4-406e-a7b2-3f6e52c69398.png"" style=""height:901px; width:797px"" /></p>
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}