import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<p>(?=<img\\s.*?))(.*?)(</p>)";
final String string = "<p><img src=\"/files/ffea8817-b5c4-406e-a7b2-3f6e52c69398.png\" style=\"height:901px; width:797px\" /></p>\n"
+ "<p><img src=\"/files/ffea8817-b5c4-406e-a7b2-3f6e52c69398.png\" style=\"height:901px; width:797px\" /></p>\n\n"
+ "<p><img src=\"/files/ffea8817-b5c4-406e-a7b2-3f6e52c69398.png\" style=\"height:901px; width:797px\" /></p>\n\n"
+ "<p><img src=\"/files/ffea8817-b5c4-406e-a7b2-3f6e52c69398.png\" style=\"height:901px; width:797px\" /></p><p><img src=\"/files/ffea8817-b5c4-406e-a7b2-3f6e52c69398.png\" style=\"height:901px; width:797px\" /></p>\n";
final String subst = "<figure class=\"image\">\\2</figure>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}