use strict;
my $str = '<p><img src="/files/ffea8817-b5c4-406e-a7b2-3f6e52c69398.png" style="height:901px; width:797px" /></p>
<p><img src="/files/ffea8817-b5c4-406e-a7b2-3f6e52c69398.png" style="height:901px; width:797px" /></p>
<p><img src="/files/ffea8817-b5c4-406e-a7b2-3f6e52c69398.png" style="height:901px; width:797px" /></p>
<p><img src="/files/ffea8817-b5c4-406e-a7b2-3f6e52c69398.png" style="height:901px; width:797px" /></p><p><img src="/files/ffea8817-b5c4-406e-a7b2-3f6e52c69398.png" style="height:901px; width:797px" /></p>
';
my $regex = qr/(<p>(?=<img\s.*?))(.*?)(</p>)/mp;
my $subst = '<figure class="image">\\2</figure>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";