import Foundation
let pattern = #"(<p>(?=<img\s.*?))(.*?)(</p>)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<p><img src="/files/ffea8817-b5c4-406e-a7b2-3f6e52c69398.png" style="height:901px; width:797px" /></p>
<p><img src="/files/ffea8817-b5c4-406e-a7b2-3f6e52c69398.png" style="height:901px; width:797px" /></p>
<p><img src="/files/ffea8817-b5c4-406e-a7b2-3f6e52c69398.png" style="height:901px; width:797px" /></p>
<p><img src="/files/ffea8817-b5c4-406e-a7b2-3f6e52c69398.png" style="height:901px; width:797px" /></p><p><img src="/files/ffea8817-b5c4-406e-a7b2-3f6e52c69398.png" style="height:901px; width:797px" /></p>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<figure class="image">\2</figure>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)