const regex = new RegExp('(<p>(?=<img\\s.*?))(.*?)(</p>)', 'gm')
const str = `<p><img src="/files/ffea8817-b5c4-406e-a7b2-3f6e52c69398.png" style="height:901px; width:797px" /></p>
<p><img src="/files/ffea8817-b5c4-406e-a7b2-3f6e52c69398.png" style="height:901px; width:797px" /></p>
<p><img src="/files/ffea8817-b5c4-406e-a7b2-3f6e52c69398.png" style="height:901px; width:797px" /></p>
<p><img src="/files/ffea8817-b5c4-406e-a7b2-3f6e52c69398.png" style="height:901px; width:797px" /></p><p><img src="/files/ffea8817-b5c4-406e-a7b2-3f6e52c69398.png" style="height:901px; width:797px" /></p>
`;
const subst = `<figure class="image">\2</figure>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);