using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[\[\w{5,}[^[\]]*\]\]";
string input = @"[[FOOTNOTE 23]] + [[FOOTNOTE 1787] + 182 - x +[[XYZ123]] + [[CD78G]]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}