// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\[\[\w{5,}[^[\]]*\]\]").unwrap();
let string = "[[FOOTNOTE 23]] + [[FOOTNOTE 1787] + 182 - x +[[XYZ123]] + [[CD78G]]";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}