const regex = new RegExp('\\[\\[\\w{5,}[^[\\]]*\\]\\]', 'gm')
const str = `[[FOOTNOTE 23]] + [[FOOTNOTE 1787] + 182 - x +[[XYZ123]] + [[CD78G]]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}