re = /\[\[\w{5,}[^[\]]*\]\]/m
str = '[[FOOTNOTE 23]] + [[FOOTNOTE 1787] + 182 - x +[[XYZ123]] + [[CD78G]]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end