import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:вул[а-яІі\\w]*[\\.\\s]*)([А-ЯІЇЄ][А-Яа-яІіЇїЄє]*) *([А-ЯІЇ]+[А-Яа-яІії]+)? *(\\d{1,3}[а-яА-Я]?)?";
final String string = "Квартира знаходиться на вул. Миколи\n\n"
+ "Квартира звучна і простора";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}