$re = '/(?:вул[а-яІі\w]*[\.\s]*)([А-ЯІЇЄ][А-Яа-яІіЇїЄє]*) *([А-ЯІЇ]+[А-Яа-яІії]+)? *(\d{1,3}[а-яА-Я]?)?/m';
$str = 'Квартира знаходиться на вул. Миколи
Квартира звучна і простора';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);