import Foundation
let pattern = #"(?:вул[а-яІі\w]*[\.\s]*)([А-ЯІЇЄ][А-Яа-яІіЇїЄє]*) *([А-ЯІЇ]+[А-Яа-яІії]+)? *(\d{1,3}[а-яА-Я]?)?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Квартира знаходиться на вул. Миколи
Квартира звучна і простора
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)