// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:вул[а-яІі\w]*[\.\s]*)([А-ЯІЇЄ][А-Яа-яІіЇїЄє]*) *([А-ЯІЇ]+[А-Яа-яІії]+)? *(\d{1,3}[а-яА-Я]?)?").unwrap();
let string = "Квартира знаходиться на вул. Миколи
Квартира звучна і простора";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}