const regex = /(?:вул[а-яІі\w]*[\.\s]*)([А-ЯІЇЄ][А-Яа-яІіЇїЄє]*) *([А-ЯІЇ]+[А-Яа-яІії]+)? *(\d{1,3}[а-яА-Я]?)?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:вул[а-яІі\\w]*[\\.\\s]*)([А-ЯІЇЄ][А-Яа-яІіЇїЄє]*) *([А-ЯІЇ]+[А-Яа-яІії]+)? *(\\d{1,3}[а-яА-Я]?)?', 'gm')
const str = `Квартира знаходиться на вул. Миколи
Квартира звучна і простора`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}