using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<a[^>]*>[^<]*<img[^>]*>[^<]*<\/a>)\r?\n?";
string input = @"<a href=""/in-bai-viet--Choang-n20120711033726647.chn"" target=""_blank"">In<img src=""/Images/printer.png"" alt=""In bài viết này"" />
</a>
<a target=""_blank"" rel=""nofollow"" href=""http://ttvn.vn/"">Thiên Lam - TTVN
</a>
<a href=""/tinh-yeu-hon-nhan/20120709102954599/Chay-lang-.chn"" title=""'abc'"">
abcd
</a>
<a href=""/in-bai-viet--Choang-n20120711033726647.chn"" target=""_blank"">In<img src=""/Images/printer.png"" alt=""In bài viết này"" />
</a>
<a target=""_blank"" rel=""nofollow"" href=""http://ttvn.vn/"">Thiên Lam - TTVN
</a>
<a href=""/tinh-yeu-hon-nhan/20120709102954599/Chay-lang-.chn"" title=""'abc'"">
abcd
</a>";
RegexOptions options = RegexOptions.Singleline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}