// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?si)(<a[^>]*>[^<]*<img[^>]*>[^<]*<\/a>)\r?\n?").unwrap();
let string = "<a href=\"/in-bai-viet--Choang-n20120711033726647.chn\" target=\"_blank\">In<img src=\"/Images/printer.png\" alt=\"In bài viết này\" />
</a>
<a target=\"_blank\" rel=\"nofollow\" href=\"http://ttvn.vn/\">Thiên Lam - TTVN
</a>
<a href=\"/tinh-yeu-hon-nhan/20120709102954599/Chay-lang-.chn\" title=\"'abc'\">
abcd
</a>
<a href=\"/in-bai-viet--Choang-n20120711033726647.chn\" target=\"_blank\">In<img src=\"/Images/printer.png\" alt=\"In bài viết này\" />
</a>
<a target=\"_blank\" rel=\"nofollow\" href=\"http://ttvn.vn/\">Thiên Lam - TTVN
</a>
<a href=\"/tinh-yeu-hon-nhan/20120709102954599/Chay-lang-.chn\" title=\"'abc'\">
abcd
</a>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}