package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?si)(<a[^>]*>[^<]*<img[^>]*>[^<]*<\/a>)\r?\n?`)
var str = `<a href="/in-bai-viet--Choang-n20120711033726647.chn" target="_blank">In<img src="/Images/printer.png" alt="In bài viết này" />
</a>
<a target="_blank" rel="nofollow" href="http://ttvn.vn/">Thiên Lam - TTVN
</a>
<a href="/tinh-yeu-hon-nhan/20120709102954599/Chay-lang-.chn" title="'abc'">
abcd
</a>
<a href="/in-bai-viet--Choang-n20120711033726647.chn" target="_blank">In<img src="/Images/printer.png" alt="In bài viết này" />
</a>
<a target="_blank" rel="nofollow" href="http://ttvn.vn/">Thiên Lam - TTVN
</a>
<a href="/tinh-yeu-hon-nhan/20120709102954599/Chay-lang-.chn" title="'abc'">
abcd
</a>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}