#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[\s\S]+"
Local $sString = "AAA123" & @CRLF & _
"ABCDEFGH123" & @CRLF & _
"XXXX123" & @CRLF & _
"" & @CRLF & _
"AAA123" & @CRLF & _
"ABCDEFGH123" & @CRLF & _
"XXXX123" & @CRLF & _
"" & @CRLF & _
"AAA123" & @CRLF & _
"ABCDEFGH123" & @CRLF & _
"XXXX123"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")