re = /[\s\S]+/
str = 'AAA123
ABCDEFGH123
XXXX123
AAA123
ABCDEFGH123
XXXX123
AAA123
ABCDEFGH123
XXXX123'
# Print the match result
str.match(re) do |match|
puts match.to_s
end