package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[\s\S]+`)
var str = `AAA123
ABCDEFGH123
XXXX123
AAA123
ABCDEFGH123
XXXX123
AAA123
ABCDEFGH123
XXXX123`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}